GSM Shop
GSM-Forum  

Welcome to the GSM-Forum forums.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features.
Only registered members may post questions, contact other members or search our database of over 8 million posts.

Registration is fast, simple and absolutely free so please - Click to REGISTER!

If you have any problems with the registration process or your account login, please contact contact us .

Go Back   GSM-Forum > GSM & CDMA Phones / Tablets Software & Hardware Area > Nokia > Nokia Legacy Phones ( DCT-1 ,2 ,3 ,L )

Nokia Legacy Phones ( DCT-1 ,2 ,3 ,L ) Nokia Legacy Models Like 1011, 1610, 211x, 2x20, 6050, 3110, 8110, NKxxx , 2100, 3210, 3310, 3330, 3410, 5110, 5210, 5510, 6110, 6150, 6210, 6250, 7110, 8210, 8250, 8850 also 9110 & 9210

Reply
 
LinkBack Thread Tools Display Modes
Old 11-20-2001, 01:27   #1 (permalink)
Freak Poster
 
Join Date: Sep 2001
Location: Spain
Posts: 109
Member: 6263
Status: Offline
Thanks Meter: 0
Unhappy STRANGE ContactService IN 8210 5.21 PLEASE READ!!!


The problem appeared after charging battery, after that I unplugged the phone from the charger, it reset and I get Contact Service...

Any Idea?

I tried to flash from 20-3d and nothing... still contact service.<br />I dissasembled the phone, cleaned it with cleaner sprays (dust cleaner) and nothing too<br />I connected it to wintesla, make self tests to know where is the problem and ALL tests passed.<br />I don't know how to fix!!!! What kind of hardware problem would be?

Please help!!!<br />Make suggestions!!!!

Many thanks, and best regards...
  Reply With Quote
Old 11-20-2001, 02:15   #2 (permalink)
Freak Poster
 
Join Date: Sep 2001
Location: Spain
Posts: 109
Member: 6263
Status: Offline
Thanks Meter: 0
Unhappy

Sorry, I put here the Self Test Results... there's 2 errors, please explain this...

MCU ROM CHECKSUM: PASSED<br />MCU RAM INTERFACE: PASSED<br />MCU RAM COMPONENT: PASSED<br />MCU EEPROM INTERFACE: PASSED<br />MCU EEPROM COMPONENT: NOT VALID<br />RTC BATTERY: PASSED<br />CCONT INTERFACE: PASSED<br />A/D CONVERTER: PASSED<br />SW RESET: PASSED<br />POWER OFF: NOT EXECUTED<br />SECURITY DATA: PASSED<br />EEPROM TUNE CHECKSUM: PASSED<br />PPM CHECKSUM: PASSED<br />MCU DOWNLOAD DSP: PASSED<br />DSP ALIVE: PASSED<br />COBBA SERIAL: PASSED<br />COBBA PARALLEL: NOT VALID (I THINK THE PROB IS HERE <img src="frown.gif" border="0"> )<br />EEPROM SEC CHECKSUM: PASSED<br />PPM VALIDITY: PASSED<br />WARRANTY STATE: PASSED

Please help!!! Any solution?
  Reply With Quote
Old 11-20-2001, 02:16   #3 (permalink)
No Life Poster
 
Bph&co's Avatar
 
Join Date: Feb 2000
Location: UK
Posts: 3,184
Member: 1024
Status: Offline
Thanks Meter: 5,504
Post

Hi,

The only way to do this is first to check with WT the reason for the CS !

Sometimes you can destroy the phone if you do something without knowing the reason.

For expample reset Full Factory when the phone is in CS caused by Cobba Parallel failed will destroy the phone IMEI and so on...

You need to be more carefull.

Best Regards
  Reply With Quote
Old 11-20-2001, 02:20   #4 (permalink)
No Life Poster
 
Bph&co's Avatar
 
Join Date: Feb 2000
Location: UK
Posts: 3,184
Member: 1024
Status: Offline
Thanks Meter: 5,504
Post

Hi,

It;s like I'm reading your mind. <img src="smile.gif" border="0">

Do this: Desolder Cobba , remove the old balls, clean it properly, clean the board.

Form the new balls and solder it again - if you lucky it will work. If the eeprom sec. data is damaged, sorry - there is not much to be done.

BR
  Reply With Quote
Old 11-20-2001, 02:26   #5 (permalink)
Freak Poster
 
Join Date: Sep 2001
Location: Spain
Posts: 109
Member: 6263
Status: Offline
Thanks Meter: 0
Dear BPH, can you help me more?

All tests ok except the cobba parallel, so, what can I do if I don't have SMD rework station to desolder cobba? Any other solution? Please, if you can contact me on MSN messenger, please contact [email protected]

Best regards
  Reply With Quote
Old 11-20-2001, 02:50   #6 (permalink)
No Life Poster
 
Bph&co's Avatar
 
Join Date: Feb 2000
Location: UK
Posts: 3,184
Member: 1024
Status: Offline
Thanks Meter: 5,504
Post

Hi,

You need to find a soldering station with the BGA tool kit or just find someone to do it for you.

The reason is that Cobba has 12 bit I/O data bus, 4 bit address bus and some more control signals - you can't know how many of them 'loose' contact so it's best to desolder the chip and put it back.

In most cases just rework won't help but try - put a flux around and just reflow it with hot air.

I hope you didn't send any security commands while tring to repair.

Best Regards, Alex
  Reply With Quote
Old 11-20-2001, 02:57   #7 (permalink)
Freak Poster
 
Join Date: Sep 2001
Location: Spain
Posts: 109
Member: 6263
Status: Offline
Thanks Meter: 0
Post

Ok, I'll try and then I will put the results here
  Reply With Quote
Old 11-20-2001, 03:01   #8 (permalink)
Freak Poster
 
Join Date: Sep 2001
Location: Spain
Posts: 109
Member: 6263
Status: Offline
Thanks Meter: 0
Post

ALex, can you contact me privately? My email is [email protected]

Best regards,

Toldien
  Reply With Quote
Old 11-20-2001, 03:04   #9 (permalink)
No Life Poster
 
makona's Avatar
 
Join Date: Nov 2000
Location: EGYPT
Age: 38
Posts: 1,198
Member: 2583
Status: Offline
Sonork: 100.88702
Thanks Meter: 201
Post

Hi Bhp&Co and all friends : <br />i know that u can help me in this problem which i asked for help for many months ago ..

i asked brobble&lead without getting replay and others via icq without understanding it !!<br />my problem :<br />- i have 8210 with Contact service<br />- in wintesla status says ( eeprom security checksum Failed )<br />- i used to repair it via N-free by ViperBJk .<br />- in this case no changes between old .fls file and new one after pressing correct CRC's in viper sw . !!<br />i think maybe viper only repair first checksum and my problem is in secound checksum ...i dunno really but i think that u can help ...<br />if u need eeprom dump i have .. tell me to send.

thnx <img src="smile.gif" border="0">
  Reply With Quote
Old 03-20-2002, 03:26   #10 (permalink)
Insane Poster
 
Join Date: Aug 2001
Location: Wallington,UK
Posts: 85
Member: 6054
Status: Offline
Thanks Meter: 0
HI,

Do you think you can send me an 8210 eeprom dump. I have V.5.20.

Cheers Mate
  Reply With Quote
Old 03-20-2002, 03:51   #11 (permalink)
Crazy Poster
 
Join Date: Oct 2001
Location: Croatia, Zagreb
Posts: 52
Member: 6960
Status: Offline
Thanks Meter: 0
Quote:
Originally posted by Bph&co
Hi,
In most cases just rework won't help but try - put a flux around and just reflow it with hot air.
Best Regards, Alex
But no longer from 15-20 sec. If it las longer, you may destroy cobba. Correct me if am wrong .

Regards,

Nicos
  Reply With Quote
Old 03-20-2002, 13:57   #12 (permalink)
No Life Poster
 
BufferMess's Avatar
 
Join Date: Mar 2002
Location: Karabakh - Azeris motherland
Age: 39
Posts: 816
Member: 9856
Status: Offline
Thanks Meter: 2
Hi all people

To toldien: Wintesla "Not valid" does not mean "Failed"

To makona: Nfree can not calculate eeprom secondary checksum!
Try Brobble`s clean eeproms.


BufferMess
  Reply With Quote
Old 03-22-2002, 08:07   #13 (permalink)
Freak Poster
 
Join Date: Jul 2001
Posts: 325
Member: 5355
Status: Offline
Thanks Meter: 5
makona

flash the eeprom part with a clean one and use nkcalc. n put ur orig imei back...

repairing chksum 2 of the eeprom by using hexworkshop would also be ok. if the data in it is still ok or intact.

maybe the corruption was so bad that nfree wasn't able to fixed it.
  Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
thread Thread Starter Forum Replies Last Post
STRANGE ContactService IN 8210 5.21 PLEASE READ!!! toldien Nokia Legacy Phones ( DCT-1 ,2 ,3 ,L ) 2 11-21-2001 07:51
STRANGE ContactService IN 8210 5.21 PLEASE READ!!! toldien Nokia Legacy Phones ( DCT-1 ,2 ,3 ,L ) 0 11-20-2001 01:34
8210 5.21 sec code please read jj008 Nokia Legacy Phones ( DCT-1 ,2 ,3 ,L ) 4 07-20-2001 17:27
If you want partials for 8210 5.27 etc... read in! G-Man Nokia Legacy Phones ( DCT-1 ,2 ,3 ,L ) 3 06-12-2001 13:54
Nokia 8210 5.21 unlocking! pioter Nokia Legacy Phones ( DCT-1 ,2 ,3 ,L ) 1 10-07-2000 16:01

 



All times are GMT +1. The time now is 11:02.



Powered by Searchlight © 2017 Axivo Inc.
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
- GSM Hosting Ltd. - 1999-2017 -
Page generated in 0.38946 seconds with 8 queries

SEO by vBSEO