GSM-Forum  

Welcome to the GSM-Forum forums.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features.
Only registered members may post questions, contact other members or search our database of over 8 million posts.

Registration is fast, simple and absolutely free so please - Click to REGISTER!

If you have any problems with the registration process or your account login, please contact contact us .

Go Back   GSM-Forum > GSM & CDMA Phones / Tablets Software & Hardware Area > Sony Ericsson > Sony Ericsson Hardware Repair

Sony Ericsson Hardware Repair Post here your Hardware Repairing Hints or Problems with SonyEricsson and Sony Phones.

Reply
 
LinkBack Thread Tools Display Modes
Old 07-11-2008, 11:43   #1 (permalink)
Freak Poster
 
Join Date: Jul 2007
Location: malaysia
Posts: 175
Member: 543544
Status: Offline
Thanks Meter: 36
w580 no display

set no drop or water damage , but no display !! already try to chg it all the ribbon insite the phone & the lcd too , still the same !! any more solution ? thanks ..
  Reply With Quote
The Following User Says Thank You to joecheun For This Useful Post:
Old 07-15-2008, 12:45   #2 (permalink)
Freak Poster
 
Join Date: Jul 2007
Location: malaysia
Posts: 175
Member: 543544
Status: Offline
Thanks Meter: 36
help !! anymore solution ......
  Reply With Quote
Old 07-16-2008, 10:44   #3 (permalink)
Freak Poster
 
Join Date: Jun 2005
Location: iran-kashan
Age: 34
Posts: 444
Member: 157053
Status: Offline
Sonork: 100.1606219
Thanks Meter: 486
you should change n1800 or other parts about light
for more help click on thanks.
  Reply With Quote
The Following 12 Users Say Thank You to morteza-icu For This Useful Post:
Show/Hide list of the thanked
Old 07-23-2008, 15:53   #4 (permalink)
Freak Poster
 
Join Date: Jul 2008
Location: P A K I S T A N
Posts: 110
Member: 805902
Status: Offline
Thanks Meter: 31
here 2 strips [ribon] or in w580 change both ur problem vil be solved..
  Reply With Quote
Old 07-26-2008, 01:31   #5 (permalink)
No Life Poster
 
Join Date: Mar 2005
Location: wales uk
Posts: 637
Member: 125632
Status: Offline
Thanks Meter: 215
Talking

i come accross 2 or 3 like this,,it seems to be where the lcd connects to the top keypad flex,there is longer connector (right next to it),main flex from the 2 halfs connects onto this,make sure this is connected sercurly,as pulling this1 apart,usually breaks connector on 1 or 2 pins,very slightly,similer prob with w850i top keypad,but not as bad......lol.....
anyway this easy to test,just pull front fasia off,carefully prise lcd away,without disconnecting,
power on mob,while pressing dwn on the long connecter.
a reflow worked for 1 mob,but new top keypad flex for the other.

on same subject,,i ava w580i,powered on great,then when screen went to standby,slide up slider,lcd lights up but the lcd just appear light blue from then on,,,try another lcd and working,but there must be some dodgy lcd for these mobs about for screen just 2 go blue like that,if i put the the faulty lcd on another mob,,still same,,light blue screen,,,phone all working in background,,,,
hope this helps some of you out
  Reply With Quote
The Following 2 Users Say Thank You to bcatlock1 For This Useful Post:
Old 11-17-2008, 10:06   #6 (permalink)
Junior Member
 
Join Date: Jun 2003
Age: 33
Posts: 25
Member: 30630
Status: Offline
Thanks Meter: 0
Hello,
I tried to replace n1800, lcd, both the strips(ribbons) but problem didnt got solved, is there any other spare that will make handset good.
Thanks & Regards.
  Reply With Quote
Old 04-24-2010, 14:08   #7 (permalink)
Junior Member
 
Join Date: Dec 2008
Location: somewhere in malaysia
Posts: 36
Member: 923809
Status: Offline
Sonork: don't what is sonork
Thanks Meter: 3
Try this may help u

Quote:
Originally Posted by azizraza View Post
Hello,
I tried to replace n1800, lcd, both the strips(ribbons) but problem didnt got solved, is there any other spare that will make handset good.
Thanks & Regards.
Try this may help u...
  Reply With Quote
Old 07-13-2010, 06:54   #8 (permalink)
Freak Poster
 
Join Date: Mar 2007
Location: Nepal
Posts: 186
Member: 477355
Status: Offline
Thanks Meter: 16
Quote:
Originally Posted by kinetic78 View Post
Try this may help u...
Try what brother,plz clear
  Reply With Quote
Old 07-30-2010, 18:53   #9 (permalink)
Junior Member
 
Join Date: Jan 2008
Location: Montevideo, Uruguay
Posts: 16
Member: 682331
Status: Offline
Thanks Meter: 2
It checks this please
  Reply With Quote
The Following User Says Thank You to tecnibros For This Useful Post:
Old 07-31-2010, 15:54   #10 (permalink)
No Life Poster
 
MIRPUR AJK's Avatar
 
Join Date: Mar 2008
Posts: 1,279
Member: 725834
Status: Offline
Thanks Meter: 916
try this solution,,,,,,,,,,,,,RapidShare: 1-CLICK Web hosting - Easy Filehosting
  Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
thread Thread Starter Forum Replies Last Post
V3 no display,no display light celluniversal Motorola P2k 21 11-21-2011 05:57
w580 blue display b12345 Sony Ericsson Hardware Repair 1 08-05-2010 20:30
w580 screen display problem after flashing sonetek SETool2 0 12-02-2009 08:47
w580 / s500 display problem brynbryn Sony Ericsson Hardware Repair 7 11-21-2009 17:58
w580 no display sandy629610 Sony Ericsson Hardware Repair 2 03-26-2009 10:14

 



All times are GMT +1. The time now is 15:42.



Powered by Searchlight © 2014 Axivo Inc.
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
- GSM Hosting Ltd. - 1999-2014 -
Page generated in 0.36513 seconds with 8 queries

SEO by vBSEO