GSM Shop GSM Shop
GSM-Forum  

Welcome to the GSM-Forum forums.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features.
Only registered members may post questions, contact other members or search our database of over 8 million posts.

Registration is fast, simple and absolutely free so please - Click to REGISTER!

If you have any problems with the registration process or your account login, please contact contact us .

Go Back   GSM-Forum > GSM & CDMA Phones / Tablets Software & Hardware Area > iPhone ,iPod & iPad (Apple Inc. Products) > iPhone 4 / iPhone 4S

iPhone 4 / iPhone 4S iPhone 4 / 4S

Reply
 
LinkBack Thread Tools Display Modes
Old 11-28-2010, 22:18   #1 (permalink)
No Life Poster
 
.::iRizwan::.'s Avatar
 
Join Date: Aug 2004
Location: زمین
Posts: 1,103
Member: 79937
Status: Offline
Sonork: 100.84313
Thanks Meter: 4,680
Donate money to this user
Lightbulb .:: (4.2.1) Unlock for iPhone 3G, 3GS Released by Dev-Team ??? ::.


Stop figuring & dreaming yourself and read carefully This.
Read,Read untill you fully understand this.
Know the Dangers & Consequences.

Any Threads regarding this will be deleted without warning or Notice.

Quote:
Today we’re pleased to announce our free carrier unlock for iPhone3G/3GS owners with a baseband later than 05.13.04. The unlock for that baseband exploited the AT+XAPP command, thanks to a crash initially discovered by @sherif_hashim (@Oranav also found this crash). So what hole are we exploiting today, since Apple closed that AT+XAPP hole? Well, we’re exploiting the exact same hole!

It turns out that the very first iPad firmware 3.2.2 has baseband version 06.15.00 still vulnerable to AT+XAPP. The iPad baseband is built for the exact same baseband chip as the iPhone3G/3GS — they’re fully compatible! Some of us have been running 06.15 for weeks now on our iPhones in preparation for this release. (And some have known about this possibility of 06.15 on the iPhones for a while — kudos to @w1kedZ and @DHowett for keeping it hush!)


SIMPLIFIED ROUTE #1 (redsn0w for OSX + Windows):
1.Read and fully understand the warning below.
2.If you have an old-bootrom 3GS and are already unlockable but want to get to 4.2.1, please wait til we release an “unofficial” bundle for you. Read no further.

3.Use redsn0w (see update #2) for OSX or Windows. Enable the “Install iPad baseband” option and accept the warning.
4.When the redsn0w ramdisk is finished, install ultrasn0w via Cydia.
5.Enjoy!


SIMPLIFIED ROUTE #2 (PwnageTool for OSX):
1.Read and fully understand the warning below.
2.If you have an old-bootrom 3GS and are already unlockable but want to get to 4.2.1, please wait til we release an “unofficial” bundle for you. Read no further.
3.Read update #1 for an updated 3GS bundle.
4.Download this IPSW
5.Run PwnageTool to create a custom 4.1 IPSW. Tell it you want to use the iPad baseband you just downloaded. Restore to this custom IPSW.
6.Install ultrasn0w through Cydia
7.Enjoy!


FULL VERSION:
Since 06.15 is a higher version than 05.14 or 05.15 (where AT+XAPP is gone), anyone stuck at those versions can simply upgrade to 06.15 to unlock again! Luckily for us, Apple *still* provides the iPad FW 3.2.2 with this vulnerable baseband right from their own servers. (Grab it now, before they take it down!)

We’ve been busy updating both PwnageTool and redsn0w to make the baseband update as seamless as possible.

1.First up is “PwnageTool 4.1.3 Unlock Edition”. It has a special dialog box which will ask you if you want to update to the iPad baseband. You must already have the iPad 3.2.2 IPSW on your computer (see the above link)….so just point PwnageTool at it (or let it find it on its own if you’re in “simple” mode).
2.Directly after PwnageTool 4.1.3 is available, the official ultrasn0w repo ultrasn0w.com will be updated with ultrasn0w 1.2, which covers iPhone 4 baseband 01.59.00 and iPhone 3G/3GS basebands 04.26.08, 05.11.07, 05.12.01, 05.13.04 and now 06.15.00.
3.Finally, we’ll release an update to redsn0w today for those without Macs and can’t run PwnageTool. The new redsn0w will give you the option to update your baseband to 06.15 too.

--------------------------------------------------------------------------------

WARNING — YOU DO THIS AT YOUR OWN RISK! PLEASE UNDERSTAND THE CONSEQUENCES OF UPDATING TO 06.15.
1.There is no way to come back down from 06.15, and there’s no hiding the baseband version from Apple. You’ll be voiding your warranty in a very obvious way.
2.If some future baseband comes out with a critical fix, you won’t be able to update to it if it remains down in the 05.xx sequence (then again, you wouldn’t update to it if you wanted to keep your unlock anyway).
3.Starting with FW 4.2.1 if you have 06.15 on your iPhone you won’t ever be able to restore to stock firmware (it will fail). You’ll need to only restore to custom IPSWs (then again, if you’re unlocker you should already be doing that).
Certainly don’t update to 06.15 if you don’t need to! Only do this if you need the unlock and you’re stuck on 05.14 or 05.15, and you’re willing to assume the above risks.


--------------------------------------------------------------------------------

This PwnageTool also contains a 4.2.1 bundle for iPhone3G owners…for all else, it’s still only 4.1. If you have an iPhone3GS with an old bootrom, use redsn0w for an untethered 4.2.1 jailbreak (it can now install the iPad baseband too). For all other devices, the 4.2.1 jailbreak is tethered only (use redsn0w for it), until @comex can work some untethering magic.

Please feel free to use our comments section for questions. We have some very knowledgeable and helpful moderators: angiepangie, Confucious, sherif_hashim, dhlizard, and Frank55!


--------------------------------------------------------------------------------

Update #1: There’s an error in the bundle for the iPhone3GS 4.1 that prevents the new baseband from being used. If you know your way around OSX, please download the fixed bundle, and unzip it if Safari hasn’t already done so. Then “Show Package Contents” of PwnageTool.app, navigate to Contents->Resources->FirmwareBundles and drop it there. Otherwise, please wait for the updated PwnageTool, or the OSX version of redsn0w coming soon.

Update #2: The new redsn0w 0.9.6beta5 is out. It gives both Windows and OSX users the ability to flash the iPad 06.15 baseband on iPhone3G or iPhone3GS. It fetches the baseband files directly from Apple for now (the only IPSW you ever point it at is the stock IPSW for the FW on your iPhone right now). There may be a long delay while it’s doing this (their servers are currently getting pounded).

OSX (SHA1 a322ec2c9e91993eca21abaf2e655bb44de3d7d4)
Windows (SHA1 7250416e17c3aea9838cdfc73712b38b025e2ed0) (Windows 7 and Vista users, please run redsn0w as Administrator in “XP Compatiblity Mode”)
If you do flash your baseband via redsn0w, please keep it plugged into USB the whole time. You don’t want your battery to die during the flash process!

Update #3: For those Mac users with an old-bootrom 3GS who really know what they’re doing, here’s a minimal 3GS 4.2.1 bundle that will get you to 4.2.1 without updating your baseband. Be sure to uncheck “Activate the iPhone” using Expert mode. To actually jailbreak after you’ve restored with the help of that bundle, please use redsn0w. If you don’t know how to drop a bundle into PwnageTool.app, please hold off on 4.2.1 until it’s untethered for everyone (or wait for a nice tutorial from somewhere like for 3G or 3GS)

Update #4: Our terrific moderators angiepangie, Confucious, sherif_hashim, dhlizard, and Frank55 have done a stupendous job moderating 7700 comments over just the first 12 hours (that’s 10 per minute for half a day!). Hats off to them, and to all of our great commenters who rack up those + points for helping total strangers jailbreak and unlock their iPhones! That’s what makes this community great

Update #5: Unlockers have been reporting mixed results about GPS functionality at 06.15.00. Until we can track down what differentiates those who retain GPS vs. those who lose it, be conservative and assume you’ll lose GPS at 06.15.00. As we work on finding the cause (and possibly a fix), please report your personal findings in our comments section. (Update: early indications are that while 06.15.00 is capable of GPS, it will require some further hacks. But please still be conservative and assume you will lose GPS at 06.15, in case the hacks don’t work).

Update #6: Developer @sbingner (author of TetherMe) has made some excellent progress devising a new hactivation method that kills two birds with one stone for all you ultrasn0w unlockers. His tool, “Subscriber Artificial Module (SAM)” tricks your iPhone and iTunes into creating legitimate activation tickets even though you’re unlocked with ultrasn0w. This means you get the full benefit of push applications, and your battery life increases substantially. If you’d like to try it out, check out http://www.bingner.com/SAM.html

To help make it easier to try out @sbingner’s tool, we’ve updated redsn0w to include a new “Deactivate” option for the 3G and 3GS. Use this option *after* you’ve installed SAM…it will remove the normal patches made to lockdownd and let SAM take over. (sbingner plans on making a button to do this within SAMPrefs too). Great work, @sbingner!

The new redsn0w with the “Deactivate” option is at:

OSX
Windows (Windows 7 and Vista users, please run redsn0w as Administrator in “XP Compatiblity Mode”)

Last edited by .::iRizwan::.; 12-04-2010 at 11:59. Reason: Update #6
  Reply With Quote
The Following 284 Users Say Thank You to .::iRizwan::. For This Useful Post:
Show/Hide list of the thanked
Old 11-28-2010, 22:23   #2 (permalink)
Insane Poster
 
Join Date: Nov 2004
Location: turkey-elazig
Age: 42
Posts: 80
Member: 91296
Status: Offline
Sonork: 100.1596673
Thanks Meter: 31
Quote:
Originally Posted by .::Rizwan::. View Post
Stop figuring & dreaming yourself and read carefully This.
Baseband 05.14.02 not unlocking
  Reply With Quote
The Following 3 Users Say Thank You to hazarhakan For This Useful Post:
Show/Hide list of the thanked
Old 11-28-2010, 22:24   #3 (permalink)
Insane Poster
 
Join Date: Nov 2010
Posts: 66
Member: 1441694
Status: Offline
Thanks Meter: 23
Quote:
Originally Posted by hazarhakan View Post
Baseband 05.14.02 not unlocking
update to the latest baseband
  Reply With Quote
The Following 5 Users Say Thank You to pro_king For This Useful Post:
Show/Hide list of the thanked
Old 11-28-2010, 22:25   #4 (permalink)
fun
No Life Poster
 
fun's Avatar
 
Join Date: Feb 2005
Location: Ireland
Posts: 1,393
Member: 117145
Status: Offline
Sonork: 1617520
Thanks Meter: 378
Quote:
Originally Posted by hazarhakan View Post
Baseband 05.14.02 not unlocking
You have to update it to 06.15 and then unlock
  Reply With Quote
The Following 5 Users Say Thank You to fun For This Useful Post:
Show/Hide list of the thanked
Old 11-28-2010, 22:26   #5 (permalink)
Junior Member
 
Join Date: Oct 2010
Posts: 9
Member: 1427002
Status: Offline
Sonork: +963
Thanks Meter: 6
Quote:
Originally Posted by hazarhakan View Post
Baseband 05.14.02 not unlocking




way
  Reply With Quote
The Following 5 Users Say Thank You to basemess For This Useful Post:
Show/Hide list of the thanked
Old 11-28-2010, 22:26   #6 (permalink)
No Life Poster
 
armany99's Avatar
 
Join Date: Oct 2004
Location: USA
Posts: 547
Member: 85637
Status: Offline
Sonork: 100.100.529
Thanks Meter: 139
i think we will wait
and check if this safty or not
  Reply With Quote
The Following 4 Users Say Thank You to armany99 For This Useful Post:
Show/Hide list of the thanked
Old 11-28-2010, 22:26   #7 (permalink)
Junior Member
 
Join Date: Mar 2009
Posts: 27
Member: 986274
Status: Offline
Thanks Meter: 6
this is a unlocker for 06.15.00 (4.2.1) datz not a bad newz....
  Reply With Quote
The Following 4 Users Say Thank You to fadisheikh For This Useful Post:
Show/Hide list of the thanked
Old 11-28-2010, 22:27   #8 (permalink)
Freak Poster
 
Join Date: Jan 2008
Posts: 459
Member: 682988
Status: Offline
Thanks Meter: 45
Quote:
Originally Posted by hazarhakan View Post
Baseband 05.14.02 not unlocking
Yes on 3Gs with bb 05.14.02 only searching...
update but !!!! have to wait
  Reply With Quote
The Following 4 Users Say Thank You to dogeatdog For This Useful Post:
Show/Hide list of the thanked
Old 11-28-2010, 22:27   #9 (permalink)
No Life Poster
 
quickgsm's Avatar
 
Join Date: Dec 2006
Location: !
Age: 34
Posts: 1,281
Member: 414755
Status: Offline
Sonork: quickgsm
Thanks Meter: 381
hhhhhhhh is just dream !!!!!!!!!!!!!!!!!!!!!!!
  Reply With Quote
The Following 2 Users Say Thank You to quickgsm For This Useful Post:
Old 11-28-2010, 22:27   #10 (permalink)
No Life Poster
 
virgin_phones's Avatar
 
Join Date: Sep 2006
Location: EARTH
Posts: 510
Member: 359939
Status: Offline
Thanks Meter: 43
i'll give dat a try!!!!!!!!!!!
  Reply With Quote
The Following 3 Users Say Thank You to virgin_phones For This Useful Post:
Show/Hide list of the thanked
Old 11-28-2010, 22:28   #11 (permalink)
Freak Poster
 
gsmtayninh's Avatar
 
Join Date: Nov 2008
Location: G̣ dầu -tây ninh
Posts: 210
Member: 896966
Status: Offline
Sonork: 100.1607398
Thanks Meter: 45
05.14.02 only searching...
  Reply With Quote
The Following 4 Users Say Thank You to gsmtayninh For This Useful Post:
Show/Hide list of the thanked
Old 11-28-2010, 22:29   #12 (permalink)
Insane Poster
 
Join Date: Nov 2004
Location: turkey-elazig
Age: 42
Posts: 80
Member: 91296
Status: Offline
Sonork: 100.1596673
Thanks Meter: 31
Quote:
Originally Posted by fun View Post
You have to update it to 06.15 and then unlock
o lala just tested.!
  Reply With Quote
The Following 2 Users Say Thank You to hazarhakan For This Useful Post:
Old 11-28-2010, 22:30   #13 (permalink)
Freak Poster
 
Join Date: Jan 2008
Posts: 459
Member: 682988
Status: Offline
Thanks Meter: 45
1.Read and fully understand the warning below.
2.Download this IPSW
3.Run PwnageTool to create a custom 4.1 IPSW. Tell it you want to use the iPad baseband you just downloaded. Restore to this custom IPSW.
4.Install ultrasn0w through Cydia
5.Enjoy!
6.If you don’t have a Mac, redsn0w will be released within a few hours to handle this.
  Reply With Quote
The Following 3 Users Say Thank You to dogeatdog For This Useful Post:
Show/Hide list of the thanked
Old 11-28-2010, 22:31   #14 (permalink)
fun
No Life Poster
 
fun's Avatar
 
Join Date: Feb 2005
Location: Ireland
Posts: 1,393
Member: 117145
Status: Offline
Sonork: 1617520
Thanks Meter: 378
Quote:
Originally Posted by virgin_phones View Post
i'll give dat a try!!!!!!!!!!!
You can try it now just you need Mac but if you using Windows then you have to wait few hour for redsnow realise.
  Reply With Quote
Old 11-28-2010, 22:42   #15 (permalink)
Freak Poster
 
BAYOO's Avatar
 
Join Date: Mar 2004
Location: Behind Enemies Lines;)@Jungle
Age: 40
Posts: 344
Member: 58608
Status: Offline
Sonork: 100.87163
Thanks Meter: 54
thanks in advanced , but more of Us havn't MAC Os in his Pc or His Laptop so can any one sharing Link for Custom 4.1 ipsw with baseband 6.15.00 to can test

Thx
BR
BAYOO
  Reply With Quote
The Following 4 Users Say Thank You to BAYOO For This Useful Post:
Show/Hide list of the thanked
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
thread Thread Starter Forum Replies Last Post
Need software upgrade for Nokia 5110 ptkrf Nokia Legacy Phones ( DCT-1 ,2 ,3 ,L ) 30 02-24-2016 09:21
DES key Driver black Nokia Legacy Phones ( DCT-1 ,2 ,3 ,L ) 8 02-08-2014 03:50
8810 mbus-cable zfrank Nokia Legacy Phones ( DCT-1 ,2 ,3 ,L ) 2 05-19-1999 13:12


All times are GMT +1. The time now is 03:28.



Powered by Searchlight © 2019 Axivo Inc.
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
- GSM Hosting Ltd. - 1999-2017 -
Page generated in 0.49705 seconds with 9 queries

SEO by vBSEO