GSM-Forum  

Welcome to the GSM-Forum forums.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features.
Only registered members may post questions, contact other members or search our database of over 8 million posts.

Registration is fast, simple and absolutely free so please - Click to REGISTER!

If you have any problems with the registration process or your account login, please contact contact us .

Go Back   GSM-Forum > GSM & CDMA Phones / Tablets Software & Hardware Area > iPhone ,iPod & iPad (Apple Inc. Products) > iPhone, iPad, iPod Hardware Repair

iPhone, iPad, iPod Hardware Repair Hardware Repair discussions for iPhone, iPod , iPad & Apple Products, help, guides.

Reply
 
LinkBack Thread Tools Display Modes
Old 11-01-2011, 12:40   #1 (permalink)
Junior Member
 
Join Date: Oct 2011
Posts: 1
Member: 1680022
Status: Offline
Thanks Meter: 0
3GS No WiFi/BT/Baseband but has UDID after reflow. (?)

Hi,
I've got an iPhone 3GS 32GB which originally came to me with iTunes Logo issue. I restored it and initially it worked (I think due to the fact the delivery warehouse was very cold and the cold soak made it work again). After a while it started failing again with the no IMEI/WiFi/Bluetooth/Baseband issue I've read about on this forum and subsequent restores gave an error (1) message and failed to restore. I also noticed that the UDID shown in the console log on my Mac was showing ffffffffffffffffffffffffffffffffffffffff. I tried it in the freezer for 30 mins and that made it work again so I concluded it was a dry solder joint on the BB CPU. This makes sense because the phone has a cracked rear cover consistent with a pretty big drop. Okay so far...

I bought a hot air gun and have had a few attempts now at reflowing the BB CPU. My method involves using some no clean liquid flux then using some heat shielding to protect adjacent components I place a small metal washer on the chip with a piece of solder in the middle. I pre-heat the entire PCB from above and below to about 100C and then apply the heat shield and heat just the BB CPU over the course of about 3.5 minutes moving the gun closer until the solder melts. I then move another 1-2 cm closer and hold for 60 seconds before starting to back off over the course of another minute or two before allowing to cool.

The result is that the phone now boots up faster (it was very slow before) and I can restore it fine from DFU mode using iTunes stock ipsw file (5.0). However, it is unable to switch on WiFi to allow the setup process and activation process to complete. I don't know if the cell signal is working as it initially says Searching and then switches to No Signal. THis might be because it can't activate.

The noticeable difference now is that I get a valid UDID number in the console logs. Does that indicate the BB CPU is working or does that come from somewhere else? Are there any other chips I should attempt to reflow? I also tried the little memory chip next to the BB CPU but that didn't help.

Any advice on what I can try next? Should I go for an oven reflow of everything? Not keen on that idea but I'm running out of options. Please help!

Thanks,
Craig.
  Reply With Quote
Old 11-01-2011, 13:29   #2 (permalink)
No Life Poster
 
Join Date: Apr 2009
Location: Wikon, Switzerland
Posts: 934
Member: 1012778
Status: Offline
Thanks Meter: 243
Hi Craig,

it seems that the Baseband still not working. From my expierience is not the BB-CPU the problem, problem is the BB-PMIC (PMB6820i) in the modem-Region of the Board. There are 2 coils. Pls check Voltage on this coils, it should be 1.8V and 1.0V
If the 1.0V have 1.3V, then is the problem on the BB-CPU side. if you have 0V and 0.6V, then you have to replace the PMB6820i or reball it. Pls ve very carefully in this region with hot air!!

BR Matthias
  Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
thread Thread Starter Forum Replies Last Post
no one can unlock 6110 05.40 25-5-99 fondas Nokia Legacy Phones ( DCT-1 ,2 ,3 ,L ) 12 09-02-2012 19:17
5110/6110 after unlocking see only network to which it was locked and ... 2M Nokia Legacy Phones ( DCT-1 ,2 ,3 ,L ) 8 07-25-2000 00:51
6150 no outgoing calls edis Nokia Legacy Phones ( DCT-1 ,2 ,3 ,L ) 1 07-20-2000 20:19
6110 unlocked but wont give reception KingOfKingston Nokia Legacy Phones ( DCT-1 ,2 ,3 ,L ) 1 04-10-2000 22:15
5110 5.24 locked all 4 locks after unlocking... MCG Nokia Legacy Phones ( DCT-1 ,2 ,3 ,L ) 3 03-07-2000 21:24

 



All times are GMT +1. The time now is 23:07.



Powered by Searchlight © 2014 Axivo Inc.
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
- GSM Hosting Ltd. - 1999-2014 -
Page generated in 0.20510 seconds with 8 queries

SEO by vBSEO