GSM-Forum  

Welcome to the GSM-Forum forums.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features.
Only registered members may post questions, contact other members or search our database of over 8 million posts.

Registration is fast, simple and absolutely free so please - Click to REGISTER!

If you have any problems with the registration process or your account login, please contact contact us .

Go Back   GSM-Forum > GSM & CDMA Phones / Tablets Software & Hardware Area > iPhone ,iPod & iPad (Apple Inc. Products) > iPhone 2 / 3G / 3GS

Reply
 
LinkBack Thread Tools Display Modes
Old 04-15-2009, 17:46   #1 (permalink)
Insane Poster
 
Join Date: Jun 2004
Location: TUNISIA
Age: 39
Posts: 67
Member: 70893
Status: Offline
Thanks Meter: 5
downgrade Baseband 20.30.03 to 02.28.00

As many know, it is currently impossible to désimlocker firmware with a Baseband 02.30.03. It is therefore mandatory in this case to downgrade the baseband. Until today, it was impossible to downgrade the Baseband charligoto but we shared some news GeoHot succeeded to make a downgrade of the Baseband 20.30.03 to 02.28.00.

So I simplified his method by creating scripts that I have gathered a few lines of code

Namely:
It is only possible to downgrade the Baseband to Bootloader 5.8. It is actually impossible if the Bootloader is version 5.9 or 6.2. (Thanks for the info Ouioui)

Preamble:
1) Open Cydia and install "MobileTerminal" and "Wget" if not already done so.
2) Quit Cydia

Preparations of necessary files:
1) Launch Terminal
2) Type "su" then return (without quotes)
3) Type in "alpine" back then (nothing will appear, this is normal, without the quotes)
4) Type "wget http://*******/tEHJc" then return (without quotes)
5) Type "sh BBdownload" then return (without quotes). Wait until the end of downloads.

Checking the version of Baseband:
1) Type "sh BBversion" then look for the "Boot Loader Version" If your bootloader is 5.8, continue the tutorial. If your bootloader is 5.9 or 6.2, expect a new version of the downgrade. That one is not currently compatible.

Downgrade the Baseband:
1) Type "sh BBexec" then return (without quotes). Wait until the installation script. Your iPhone will restart.

Go to Settings -> Information -> Baseband: The version is 02.28.00
Bravo, you can make a désimlock with Yellowsn0w if you want
If your Baseband is still 02.30.03, made following the tutorial.

1) Open Terminal
2) Type "rm / var / mobile / BB *" without quotes and press return
3) Type "rm / var / root / BB *" without quotes and press return
4) Type "rm / var / root / IC *" without quotes and press return
5) Repeat the tutorial now.
  Reply With Quote
Old 04-15-2009, 18:04   #2 (permalink)
Freak Poster
 
lotfi17's Avatar
 
Join Date: Nov 2000
Location: Oslo
Posts: 125
Member: 2616
Status: Offline
Thanks Meter: 6
Bootloader version 05.08

I really wonder how many iphones "baseband 2.30 with Bootloader version 05.08? I never seen one, just 05.09 . Some people had Bootloader version 6 but never seen that either. Anyway I believe most people got Bootloader version 05.09 even with Os 3.0 and baseband 4.20.01 the loader version is 05.09 like mine. This new solution for downgrade is not the real work. Wish u luck.
  Reply With Quote
The Following User Says Thank You to lotfi17 For This Useful Post:
Old 04-15-2009, 18:32   #3 (permalink)
No Life Poster
 
SLIPLOCK's Avatar
 
Join Date: Oct 2004
Location: Galaxy
Age: 36
Posts: 1,254
Member: 86301
Status: Offline
Thanks Meter: 105
phone with 2.2.1/2.30.03 and BL 5.08 are phone upgraded by mistake with itunes.
i think < 2.1 are in 5.08
anyway i have no proof, but some of new phone i get 2.2.1 ootb are in 5.09 or 6.02
wbr
  Reply With Quote
Old 04-16-2009, 15:45   #4 (permalink)
Junior Member
 
Join Date: Feb 2009
Posts: 38
Member: 968873
Status: Offline
Thanks Meter: 12
Yeah man I tested this solution. I had 2.2.1 with the boot loader 5.08. I did the above steps and my modem firmware is changed to 2.28. thank you very much
  Reply With Quote
Old 04-16-2009, 23:49   #5 (permalink)
Major Poster
 
Join Date: Apr 2005
Age: 51
Posts: 41
Member: 140808
Status: Offline
Thanks Meter: 2
What a star you are. Successfully downgraded baseband from 02.30.03 to 2.28.00 & unlocked with yellowsn0w. Lucky for me I also had boot loader 5.08. Tried Vodafone sim 100% unlock
  Reply With Quote
Old 04-17-2009, 00:04   #6 (permalink)
No Life Poster
 
MYUNLOCKING's Avatar
 
Join Date: Apr 2008
Location: karachi ..
Age: 29
Posts: 3,080
Member: 749969
Status: Offline
Sonork: 100.1581886
Thanks Meter: 746
plese post some video tutorial link..
  Reply With Quote
Old 04-17-2009, 00:51   #7 (permalink)
Freak Poster
 
Join Date: May 2008
Posts: 164
Member: 770274
Status: Offline
Thanks Meter: 15
i phone

Quote:
Originally Posted by mobileclinic_14 View Post
plese post some video tutorial link..
chek here

http://www.iclarified.com/entry/index.php?enid=3583
  Reply With Quote
Old 04-20-2009, 00:54   #8 (permalink)
Major Poster
 
Join Date: Apr 2005
Age: 51
Posts: 41
Member: 140808
Status: Offline
Thanks Meter: 2
is there going to be a solution for 5.09 & higher? Have tried on 6.02 & can't find ANY network. Have to restore using itunes to get original network
  Reply With Quote
Old 04-20-2009, 08:03   #9 (permalink)
No Life Poster
 
nishaon's Avatar
 
Join Date: Jan 2006
Location: Deep Blue G.S.M.
Posts: 2,378
Member: 225229
Status: Offline
Thanks Meter: 89
Quote:
Originally Posted by elmersattic View Post
is there going to be a solution for 5.09 & higher? Have tried on 6.02 & can't find ANY network. Have to restore using itunes to get original network
You have nothing to do at the moment except waiting.
  Reply With Quote
Old 04-20-2009, 09:37   #10 (permalink)
Freak Poster
 
Join Date: Dec 2004
Posts: 195
Member: 97346
Status: Offline
Thanks Meter: 14
i had Boot Loader Version: ICE2_BOOT_05.08_G2M3S2 and i tried earlier in modem 4.20.01 but i failed...



rgds..
  Reply With Quote
Old 04-20-2009, 09:38   #11 (permalink)
Freak Poster
 
Join Date: Dec 2004
Posts: 195
Member: 97346
Status: Offline
Thanks Meter: 14
i had Boot Loader Version: ICE2_BOOT_05.08_G2M3S2 and i tried earlier in modem 4.20.01 but i failed...



rgds..
  Reply With Quote
Old 04-20-2009, 10:59   #12 (permalink)
No Life Poster
 
zino's Avatar
 
Join Date: Dec 2002
Location: HYDRA.anyone know were.
Age: 46
Posts: 639
Member: 18688
Status: Offline
Thanks Meter: 67
Quote:
Originally Posted by lotfi17 View Post
I really wonder how many iphones "baseband 2.30 with Bootloader version 05.08? I never seen one, just 05.09 . Some people had Bootloader version 6 but never seen that either. Anyway I believe most people got Bootloader version 05.09 even with Os 3.0 and baseband 4.20.01 the loader version is 05.09 like mine. This new solution for downgrade is not the real work. Wish u luck.
I too have never seen one,
  Reply With Quote
Old 04-21-2009, 09:13   #13 (permalink)
Freak Poster
 
Join Date: Dec 2004
Posts: 195
Member: 97346
Status: Offline
Thanks Meter: 14
i tried this procedure in my iphone with bootloader 5.08 and a modem FW 4.20.01 but i failed again...

i got error onGetting EBL Version................Timed out

it loops over and over for about 9 times i think..
  Reply With Quote
Old 04-21-2009, 18:31   #14 (permalink)
No Life Poster
 
SLIPLOCK's Avatar
 
Join Date: Oct 2004
Location: Galaxy
Age: 36
Posts: 1,254
Member: 86301
Status: Offline
Thanks Meter: 105
of course.
for 4.20.01 you need patched ICE2_2.28.00.fls with 4.20.01 certificates.
if you have this file you can downgrade.
wbr
  Reply With Quote
Old 04-21-2009, 20:36   #15 (permalink)
No Life Poster
 
Brka's Avatar
 
Join Date: Jun 1999
Location: Serbia
Age: 38
Posts: 2,300
Member: 163
Status: Offline
Thanks Meter: 890
How to Downgrade Your iPhone 3G 2.30 (2.2.1) Baseband for Unlock Tutorial Here !!!
  Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
thread Thread Starter Forum Replies Last Post
downgrade i-phone baseband 2.30.03 to2.28 ..::ohm::.. iPhone 2 / 3G / 3GS 8 04-24-2009 12:14
downgrade baseband 2.30.03 to 2.28 jitender87 iPhone 2 / 3G / 3GS 6 04-19-2009 07:53
Downgrade iPhone Baseband From 02.30.03 To 02.28.00 mani_satcell iPhone 2 / 3G / 3GS 2 04-15-2009 16:15
How to Downgrade Baseband 2.30.03 to 2.28.00 jinxgsm iPhone 2 / 3G / 3GS 23 03-13-2009 10:26

 



All times are GMT +1. The time now is 03:58.



Powered by Searchlight © 2014 Axivo Inc.
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
- GSM Hosting Ltd. - 1999-2014 -
Page generated in 0.37232 seconds with 8 queries

SEO by vBSEO