View Single Post
Old 09-16-2021, 17:58   #4 (permalink)
preacher23
Junior Member
 
Join Date: Nov 2007
Posts: 13
Member: 633412
Status: Offline
Thanks Meter: 1
Greetings,

I have a few questions about the symptoms I'm having with this phone (A125W)

I have, 1 phone that is working well, it was successfully rooted via magisk, and is running the latest update A125WOYV2AUG5.

Using this phone, I took a complete backup (MTK Mode):

Calibration files (nvram, protect1, protect2, seccfg, misc, nvcfg, nvdata, proinfo)
Firmware files (efs, sec_efs, steady, spmfw, etc)
Miscellaneous (cache, userdata)
Special (partition_table, secondary_partition_table, region-0x0, etc)

Then i have a second phone same model, same fw and I took a full backup of it as well (MTK Mode)

The symptom i'm having is when the user makes the first phone call which works fine and indicates there is no hardware problem, or modem firmware problem, after the phone call ends (user hangs up) 2 seconds later the IMEI and BASEBAND show UNKNOWN.

I factory reset it, the IMEI and BASEBAND come back, then I make a phone call and lose them again, over and over.

I tried flashing original Factory FW A125WOYV2AUFA (previous to this one) via odin same results

I even try to flash everything (MTK MODE) from the working phone to the broken phone, but when doing that, the baseband is unknown and imei blank no matter what i do so there must be a mechanism that prevents (cloning)

This symptom began when the user programmed the phone using ODIN incorrectly by selecting the fifth checkmark (USERDATA) and flashing:
HOME_CSC_OMC_OYV_A125WOYV2AUG5_CL21871223_QB419499 25_REV00_user_low_ship_MULTI_CERT in it.

So basically the user selected BL, AP, CP, CSC but additionaly loaded the HOME_CSC into the USERDATA checkbox in odin and flashed them.

The phone shows:
FRP LOCK OFF
OEM LOCK OFF (U)
KG STATUS: CHECKING
MTK SECURE BOOT: ENABLE(0)
SECURE DOWNLOAD: ENABLE

I managed to figure out that the nvdata partition is what is being "corrupted" or "modified" by the system. Because when the IMEI/BASEBAND become unknown, I flashed back just nvdata (MTK Mode) and they came back, make a phone call, hangup, gone again, flash it back, and again IMEI is back.

Does anyone known what is causing this issue? is there a security mechanism? What must I do to restore this phone to working order.

If anyone can shed some light on this issue, it would be greatly appreciated.

Last edited by preacher23; 09-16-2021 at 18:02. Reason: clarity
  Reply With Quote
 
Page generated in 0.07127 seconds with 7 queries