GSM-Forum

GSM-Forum (https://forum.gsmhosting.com/vbb/)
-   GSD Dongle (https://forum.gsmhosting.com/vbb/f1108/)
-   -   How to root mediatek device in bootrom mode with GSD Pro (https://forum.gsmhosting.com/vbb/f1108/how-root-mediatek-device-bootrom-mode-gsd-pro-3002208/)

ilya20 01-22-2022 13:07

How to root mediatek device in bootrom mode with GSD Pro
 
Hello to all

You can root any mediatek devices with gsd dongle , follow this toturial for rooting device in bootrom mode.

Requirements:
this option is received needed partitions from device and no need any firmware and more
  1. The device you want to root.
  2. Another device that is connected in adb mode.


How to root device
  1. Goto GSD Mediatek Features More service
  2. Enable GSD Engine
    http://www.gsm-developers.com/wp-con...1/Untitled.png

  3. Make sure your device is unlocked bootloader before doing this (if the bootloader is not unlocked,First use the GSD unlock bootloader option)
  4. Click root device and hold bootkey and connect device
  5. wait for reading partitions from device
    http://www.gsm-developers.com/wp-con.../2022/01/2.png

  6. After receiving the partitions, GSD wants you to connect a device in adb mode.do not disconnect device, GSD needs another device and it does not matter what device model it is.
    http://www.gsm-developers.com/wp-con.../2022/01/3.png

  7. wait for patching partitions
    http://www.gsm-developers.com/wp-con.../2022/01/4.png

  8. wait for flashing partitions
    http://www.gsm-developers.com/wp-con.../2022/01/5.png


  9. And finally Task is complete
    http://www.gsm-developers.com/wp-con.../2022/01/6.png

Code:

Receiving Structure from server :Received
Receiving Structure from server :Ok
1- Power Off Device
2- Hold boot key And Connect To PC

Waiting for MTK Serial Port (Timeout 3 minute) : Ok
Handshake device : Ok
Reading device Info :
BROM mode detected.Ok
Platform : 6765
Hardware Sub Code : 0x8a00
Hardware Code : 0x766
Hardware Version : 0xca00
Software Version : 0x00
Is Secure boot : True
Serial Link authorization Protect : True
download agent authorization Protect : True
SWJTAG enabled: True
EPP_PARAM at 0x600 after EMMC_BOOT/SDMMC_BOOT: False
Root cert required: True
Mem read auth: True
Mem write auth: True
Cmd 0xC8 blocked: True
ME_ID: 0xEAA1723ABCD885AB5232FAF87EE78A67
SOCID: 0x1FFA3B2FB25322046BB836576E2B1C584E8E053C8F2F6A1111987E5F4132C904
Checking Device is Support : Ok
CPU Info : MT6765 Helio P35/G35
Disabling Watchdog timer : Ok
Disabling SLA\DAA Security : Ok
Choosing the right da : Ok
Receiving EMI: Ok
Writing download agent : Ok
Jumping Download Agent : Ok
Sync signal : Ok
Setup environment : Ok
Setup param : Ok
Receiving Storage info : emmc
dram config needed for : 0x90014A4841473461
Connection Status : brom service
Sending emi : Ok
booting device to da :
Receiving Memory info : Ok
dram type : 0x0000000000000001
dram size : 0x0000000080000000 (2 GB)
dram base address : 0x0000000040000000
sram type : 0x0000000000000002
sram size : 0x000000000003a000 (232 KB)
sram base address : 0x0000000000200000
Receiving Storage info : Ok
emmc cid : 0x90014A484147346132A5C2F9CC14756B
emmc boot1 size : 0x0000000000400000 (4 MB)
emmc boot2 size : 0x0000000000400000 (4 MB)
emmc gp1 size : 0x0000000000000000 (0 B)
emmc gp2 size : 0x0000000000000000 (0 B)
emmc gp3 size : 0x0000000000000000 (0 B)
emmc gp4 size : 0x0000000000000000 (0 B)
emmc rpmb size : 0x0000000000400000 (4 MB)
emmc user size : 0x00000003ab400000 (14.676 GB)
Receiving configuration : Ok
Usb Speed : high-speed0x417904660
Excuting DA Extensions :
DA-CODE : Ok
Brand: xiaomi
Manufacturer: Xiaomi
Model: Redmi 6A
Build Number: V11.0.8.0.PCBMIXM
Android Version: 9
SDK Version: 28
Model ID: SW_S98506AE1_V009_M13_XM_C3C_USR
Processor: armeabi-v7a
Local: en-GB
Security Path: 2020-05-01
Reading Partition Information tables from device : Ok
Count of partition finded : 41
Reading boot Partition : Ok
Reading vbmeta Partition : Ok
Unpacking image : Ok
Device Type : Board Name :
Board Base : 0x40000000
Board Hash : sha1
Page size : 2048
Kernel offset : 0x00008000
Ramdisk offset : 0x11b00000
Board Second offset : 0x00f00000
Board tags offset : 0x07880000
Image type : AOSP
Os version : 9.0.0
Release date : 2020-05
Checking binary : Ok
Patching device : OkOk
Flashing boot Partition : Ok
Flashing vbmeta Partition : Ok
elapsed Time for this operation:00:02:07.7997133


Southsider2009 01-23-2022 19:50

I am definitely gonna try this. That's the sole reason I bought GSD Dongle

Southsider2009 02-02-2022 18:58

I have tried. Still not working. If you think am doing it wrongly. Please connect to my PC via team viewer and try

ilya20 02-02-2022 19:38

Quote:

Originally Posted by Southsider2009 (Post 14512659)
I have tried. Still not working. If you think am doing it wrongly. Please connect to my PC via team viewer and try

send me your anydesk in my telegram
@gsm_developers

ilya20 02-09-2022 23:06

Root samsung SM-A013G in brom Mode with GSD Pro just one click
http://www.youtube.com/watch?v=ScIvSR6ml5A


All times are GMT +1. The time now is 13:10.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2022 DragonByte Technologies Ltd.
- GSM Hosting Ltd. - 1999-2017 -

Page generated in 0.09204 seconds with 6 queries

SEO by vBSEO