GSM-Forum

GSM-Forum (https://forum.gsmhosting.com/vbb/)
-   Cyclonebox (https://forum.gsmhosting.com/vbb/f528/)
-   -   Box Selftests Fail, What to do.... (https://forum.gsmhosting.com/vbb/f528/box-selftests-fail-what-do-812599/)

ptt 08-25-2009 00:46

Box Selftests Fail, What to do....
 
For those who have Box Selftests Fail Warnings, a litle guide....

1- Normal result of Selftests ( box is OK nothing to worry )

Code:


USB Voltage 4.94v PASSED
MCU Voltage 3.28v PASSED
Core Voltage 1.78v PASSED
VBAT Voltage 0.01v PASSED
VBAT Voltage 4.91v PASSED
Box VPP disabled
VPP Voltage 0.04v PASSED
Internal Box VPP Enabled
VPP Voltage 4.86v PASSED
Box VPP disabled
VPP Voltage 0.04v PASSED
External Box VPP Enabled
VPP Voltage 0.04v FAILED - IGNORED -
Probably power supply is not connected 
( nothing to worry,
this error is because the external VPP power supply is not conected )


2- VPP Supply Voltage test failed

Code:


Internal Box VPP Enabled
Box Selftests Failed -> VPP Supply Voltage test failed,
1.25v is out of valid range
 
In this case, contact your reseller for Box exchange

3- VBAT Supply test fail

Code:


VBAT Voltage 0,01v PASSED
Box Selftests Failed -> VBAT Supply Voltage test failed,
0,03v is out of valid range
 
In this case you have to check ( with a multimeter )
if you have the correct voltage at F-Bus Battery contacts....
or if using an Unifbus, between red an black clips 
( normal values are close to USB Voltage )
 
If dont get voltage or this is very low ( 0.03V,1.2V, 1.5V 2.4V, etc),
then you must contact your reseller for Box Exchange.


For more info, Use Search, Read sticky posts, there is alot of info already posted....
BR

sameenshah123 08-25-2009 13:44

Internal Box VPP Enabled
Box Selftests Failed -> VPP Supply Voltage test failed,
1.25v is out of valid range

In this case, contact your reseller for Box exchange

this is my error. and bought from *************. and to that box back its cost me too much. i already paid 146 for box and 100 usd from delivery. is there any easy way to fix this problem

ptt 08-25-2009 19:13

@ sameenshah123

read here how VPP works:

http://forum.gsmhosting.com/vbb/show...9&postcount=61

Here an easy way to check VPP:

http://forum.gsmhosting.com/vbb/show...27&postcount=9

If your box is ones with the old HW, as mine (using LM1950T)

http://img91.imageshack.us/img91/4992/04012009062.jpg


http://forum.gsmhosting.com/vbb/atta...3&d=1245914162

you can tray resolder U5 ( LM1950T )
if this dont solve the problem, then you need to change the U5... you can remove U4 (used for switch ext VPP) and use it to replace U5, doing this you recover the Internal Box VPP function, and loose the ext VPP function...

sameenshah123 08-25-2009 19:39

witch box hardware is better old or new. man i am in big trouble coz i am not got to fix hardware.

ptt 08-25-2009 19:58

I think there is at least 3 diferent HW versions, the first with LM1950T ( i have this ), the second with CS8240, and the third with LM3526H.... i cant say which is better as i only have 1....

If you dont have the skill to do the tests posted, then better contact reseller, or Mr. Cyclonebox ( see this post )

http://forum.gsmhosting.com/vbb/show...2&postcount=25

BR

karwos 08-26-2009 19:24

Thanks ptt for your superb suppport !

sameenshah123 08-26-2009 20:12

man today i open my box and i saw its have LM3526H should i change these 2 ice. coz i cyclone can read phone when conect cable direct to box without tx2 adapter. but with adapter its dont detect. and box self test fail.and some time box self test ok. i can flash dct4 phone and unlcok and as well bb5 unlock but not flash. plz tell me sould i change these 2 ice. and i cant get (LM3526H) i found uc3526h) is it ok to replace with this ic. ?

karwos 08-26-2009 20:19

Quote:

Originally Posted by sameenshah123 (Post 4785277)
man today i open my box and i saw its have LM3526H should i change these 2 ice. coz i cyclone can read phone when conect cable direct to box without tx2 adapter. but with adapter its dont detect. and box self test fail.and some time box self test ok. i can flash dct4 phone and unlcok and as well bb5 unlock but not flash. plz tell me sould i change these 2 ice. and i cant get (LM3526H) i found uc3526h) is it ok to replace with this ic. ?

Better check your adapter solderings, if you conncet directly to box and it works that means your box hardware is perefect

TRABEL 08-26-2009 21:11

well , mine all tests are o.k
thought im getting error when tma adapter conected to box with usb power ,then i get error . if i disconect the usb power , then all tests going fine ...
ideas ?

sameenshah123 08-26-2009 21:21

Quote:

Originally Posted by Cyclonebox (Post 4785296)
Better check your adapter solderings, if you conncet directly to box and it works that means your box hardware is perefect

i also open tx2 adapter. there 10 soldring point. and all sold well. i was also suspecting problem should be in adapter. can u plz give any hint or trick that i check adapter. i mean how to check adapter. if solding is ok. what wire to check with meter. i am that good in hard ware. plz sugestion ?

moulnisky 08-26-2009 22:23

Quote:

Originally Posted by TRABEL (Post 4785416)
well , mine all tests are o.k
thought im getting error when tma adapter conected to box with usb power ,then i get error . if i disconect the usb power , then all tests going fine ...
ideas ?

It is a little "hole" in the project of the tma adapter 1.1. The usb cable is connected to the Pin 1 of the adapter (Vbatt); if you connect the TMA to the box and you start the program, the self test check all the configurations; one of the test is the Vbat .. test one Vbatt must be about 5 V if needed and this test pass.. second part is Vbatt must be 0 if needed but whatever the box sto giving power to the vbatt the test read 5 Volts coming from the adapter USB cable to the pin1 and you get the error. was enaugh one diode on the pin 1 to prevent this error..
Obviously this error doesn't happen with the tma evolution.

BR

Alex

haddad79 08-29-2009 07:00

Mr Ptt
i have this problem
Code:

Nokia DCT4/WD2/BB5 Service Tool Initialization Started, Engine Revision: 1.0.0.7828
Handling device: [Cyclone Team], [Cyclone Bootloader]
Handling device: [Cyclone Team], [Cyclone Box]
Initializing box...
Box Firmware: Cyclone Nokia Application v1.06, (Aug  8 2009 17:54:19, gcc-4.2.2, RTOS v5.2.0), Type: Signed Production Application, Flags: Revised
Box Serial Number: 00000
HW Revision: A, Suitable for: Production, Case: First Plastic Case, MCU Manufacture Time: Unknown
Initializing security card...
Card Serial Number: 00000
Card Firmware Revision: 0109
Card is activated
Box is activated
Started box selftests procedure
USB Voltage        4.95v        PASSED
MCU Voltage        3.28v        PASSED
Core Voltage        1.76v        PASSED
VBAT Voltage        3.39v        PASSED
Box Selftests Failed -> VBAT Supply Voltage test failed, 3.39v is out of valid range
Initializing FBUS...
All initialized - Ready to work

and same times give me this
[/CODE]Started box selftests procedure
USB Voltage 4.94v PASSED
MCU Voltage 3.28v PASSED
Core Voltage 1.76v PASSED
Box Selftests Failed -> VBAT Supply Voltage test failed, 4.42v is out of valid range
Initializing FBUS...
All initialized - Ready to work[/CODE]
What can i do to fix this problem

ptt 08-29-2009 11:30

You get the error when start the soft with cable conected to Service socket ? Is better to start the software without cable conected at Service port.

If the error produces randomly, you can verify if the voltage at VBAT terminals of FBUS cable is correct ( if box say 3.39V and you get near 4.8V then is calibartion resistors, and is not to worry about )

If you get the voltages that Box say in box selftests, then maybe you have bad solders at IC which manages VBAT...

BR

deal1975 08-29-2009 14:21

hello , here with my box only green light is on , nothing no reaction

ptt 08-29-2009 22:46

@ deal1975

Hi, the green led remains ON, and nothing more hapens ? PC detects Box and ask for drivers ? If the PC cant detect your box i think you need contact your reseller for Box Exchange....

I sugest you, open a new thread regarding your problem, here we are talking about "Box Seltests Fail" problem...

BR


All times are GMT +1. The time now is 06:16.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
- GSM Hosting Ltd. - 1999-2017 -

Page generated in 0.15458 seconds with 6 queries

SEO by vBSEO