GSM Shop GSM Shop
GSM-Forum  

Welcome to the GSM-Forum forums.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features.
Only registered members may post questions, contact other members or search our database of over 8 million posts.

Registration is fast, simple and absolutely free so please - Click to REGISTER!

If you have any problems with the registration process or your account login, please contact contact us .

Go Back   GSM-Forum > GSM & CDMA Phones / Tablets Software & Hardware Area > Nokia > Nokia Windows & MeaMo/MeeGo based

Nokia Windows & MeaMo/MeeGo based N900,N9,N950,700,710,N800,800,920,925 etc all linux and WP phones flashing & unlocking only here

Reply
 
LinkBack Thread Tools Display Modes
Old 06-01-2020, 14:09   #1 (permalink)
Junior Member
 
Join Date: Aug 2010
Posts: 2
Member: 1365488
Status: Offline
Thanks Meter: 1
lumia 920 won't boot uo


hey all, when i got this phone, i was told it just had a dead battery. put it on the charger and it never charged up. the screen just showed that i needed to charge the battery. i did the power & volume button trick, and the at&t logo showed up, then went back to dead. so i pulled the battery and tested it for charge. it came back 3.5v. then i checked the charging port, and the contact part was broken. put in a new cable & port. still showing battery needs charging. got a different battery, still shows battery needs charging. only booting to at&t logo. what can i check or do next? thanx!
  Reply With Quote
The Following User Says Thank You to chowceal For This Useful Post:
Old 12-15-2020, 08:12   #2 (permalink)
Junior Member
 
Join Date: Apr 2018
Posts: 1
Member: 2831556
Status: Offline
Thanks Meter: 0
i installed the original battery, got a GOOD usb data cable, left it plugged in after a forced reboot for 2 days, cost me $15 U.S. on ebay for that phone. needs a screen cuz the seller didn't know how to you-tube bat replacement.
  Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


 



All times are GMT +1. The time now is 20:33.



Powered by Searchlight © 2022 Axivo Inc.
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2022 DragonByte Technologies Ltd.
- GSM Hosting Ltd. - 1999-2017 -
Page generated in 0.11198 seconds with 7 queries

SEO by vBSEO