GSM Shop GSM Shop
GSM-Forum  

Welcome to the GSM-Forum forums.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features.
Only registered members may post questions, contact other members or search our database of over 8 million posts.

Registration is fast, simple and absolutely free so please - Click to REGISTER!

If you have any problems with the registration process or your account login, please contact contact us .

Go Back   GSM-Forum > Product Support Sections > Hard/Software Products (official support) > Chimera Tool

Reply
 
LinkBack Thread Tools Display Modes
Old 09-15-2021, 04:29   #1 (permalink)
Junior Member
 
Join Date: Nov 2007
Posts: 13
Member: 633412
Status: Offline
Thanks Meter: 1
SM-A125W Imei Not Found ?


Hey there,


I have a fully functional SM-A125W and another one that keeps losing IMEI after factory reset and making a phone call.


I just plugged in the fully functional one, and it's saying (in MTK mode) that the imei was not found.


Also, the one that keeps losing it's imei and baseband after the first phone call after a factory reset, i tried the restore imei function and it didn't work either.


Code:
Chimera Mobile Phone Utility version: 29.61.0725  2021-09-14
Autodetect features
Initializing...
Identifying...
Reading data from the phone...
Autodetect features
Reading data from the phone...
Couldn't mount userdata. Probably it's encrypted.
IMEI not found
WorkID: 150424170
  Reply With Quote
Old 09-15-2021, 09:34   #2 (permalink)
Product Manager
 
Chimera Tool's Avatar
 
Join Date: Jul 2012
Posts: 18,969
Member: 1787203
Status: Offline
Thanks Meter: 19,356
reply

Dear User,

Based on your works with the device, in MTK mode we cannot provide you the IMEI REPAIR.

But if you change the module to Samsung (in the chimera tool you should see that option once you connect the phone to the tool) you have to see the IMEI REPAIR method. Can you please run that?

Best regards
Sab
Chimera Team


Quote:
Originally Posted by preacher23 View Post
Hey there,


I have a fully functional SM-A125W and another one that keeps losing IMEI after factory reset and making a phone call.


I just plugged in the fully functional one, and it's saying (in MTK mode) that the imei was not found.


Also, the one that keeps losing it's imei and baseband after the first phone call after a factory reset, i tried the restore imei function and it didn't work either.


Code:
Chimera Mobile Phone Utility version: 29.61.0725  2021-09-14
Autodetect features
Initializing...
Identifying...
Reading data from the phone...
Autodetect features
Reading data from the phone...
Couldn't mount userdata. Probably it's encrypted.
IMEI not found
WorkID: 150424170
  Reply With Quote
Old 09-16-2021, 16:41   #3 (permalink)
Junior Member
 
Join Date: Nov 2007
Posts: 13
Member: 633412
Status: Offline
Thanks Meter: 1
Greetings:


Code:
Chimera Mobile Phone Utility version: 29.67.2050  2021-09-16
Repair started
Unable to detect IMEI number and baseband version. It seems that the modem does not work or the network is unavailable/disabled.
Gathering phone info...
Collecting information. Be patient! Do NOT disconnect the phone!
Model: SM-A125W
Carrier ID: XAC
Sales Code: BMC
Country Code: Canada
Timezone: America/New_York
Android Version: 11 [RP1A.200720.012] [SDK 30]
Build Date: Tue Jul 27 14:10:03 KST 2021
PDA Version: A125WVLU2AUG5 [july 2021, rev5]
CSC Version: A125WOYV2AUG5 [july 2021, rev5]
Board Platform: MT6765
Network Type: GSM
Multisim Config: SS
Knox Version: v30
Warranty Bit: 1
Security Patch: 2021-07-01
Em Did: 5925C15534F3
Repair imei...
Restarting phone.
Waiting for ADB connection. Be patient! Do NOT disconnect the phone!
The operation is in progress. Be patient! Do NOT disconnect the phone!
Unknown modem
Finished at local time: [09.16.21 11:39:59]
WorkID: 150676483
  Reply With Quote
Old 09-16-2021, 17:58   #4 (permalink)
Junior Member
 
Join Date: Nov 2007
Posts: 13
Member: 633412
Status: Offline
Thanks Meter: 1
Greetings,

I have a few questions about the symptoms I'm having with this phone (A125W)

I have, 1 phone that is working well, it was successfully rooted via magisk, and is running the latest update A125WOYV2AUG5.

Using this phone, I took a complete backup (MTK Mode):

Calibration files (nvram, protect1, protect2, seccfg, misc, nvcfg, nvdata, proinfo)
Firmware files (efs, sec_efs, steady, spmfw, etc)
Miscellaneous (cache, userdata)
Special (partition_table, secondary_partition_table, region-0x0, etc)

Then i have a second phone same model, same fw and I took a full backup of it as well (MTK Mode)

The symptom i'm having is when the user makes the first phone call which works fine and indicates there is no hardware problem, or modem firmware problem, after the phone call ends (user hangs up) 2 seconds later the IMEI and BASEBAND show UNKNOWN.

I factory reset it, the IMEI and BASEBAND come back, then I make a phone call and lose them again, over and over.

I tried flashing original Factory FW A125WOYV2AUFA (previous to this one) via odin same results

I even try to flash everything (MTK MODE) from the working phone to the broken phone, but when doing that, the baseband is unknown and imei blank no matter what i do so there must be a mechanism that prevents (cloning)

This symptom began when the user programmed the phone using ODIN incorrectly by selecting the fifth checkmark (USERDATA) and flashing:
HOME_CSC_OMC_OYV_A125WOYV2AUG5_CL21871223_QB419499 25_REV00_user_low_ship_MULTI_CERT in it.

So basically the user selected BL, AP, CP, CSC but additionaly loaded the HOME_CSC into the USERDATA checkbox in odin and flashed them.

The phone shows:
FRP LOCK OFF
OEM LOCK OFF (U)
KG STATUS: CHECKING
MTK SECURE BOOT: ENABLE(0)
SECURE DOWNLOAD: ENABLE

I managed to figure out that the nvdata partition is what is being "corrupted" or "modified" by the system. Because when the IMEI/BASEBAND become unknown, I flashed back just nvdata (MTK Mode) and they came back, make a phone call, hangup, gone again, flash it back, and again IMEI is back.

Does anyone known what is causing this issue? is there a security mechanism? What must I do to restore this phone to working order.

If anyone can shed some light on this issue, it would be greatly appreciated.

Last edited by preacher23; 09-16-2021 at 18:02. Reason: clarity
  Reply With Quote
Old 09-19-2021, 16:49   #5 (permalink)
Junior Member
 
Join Date: Nov 2007
Posts: 13
Member: 633412
Status: Offline
Thanks Meter: 1
anyone have any clues please ?
  Reply With Quote
Old 09-20-2021, 10:22   #6 (permalink)
Product Manager
 
Chimera Tool's Avatar
 
Join Date: Jul 2012
Posts: 18,969
Member: 1787203
Status: Offline
Thanks Meter: 19,356
reply

Dear User,

Based on the log that you posted (thank you for it), the device modem is not working. I would recommend to reflash the phone with stock firmware, then if you can, repair the EFS partition (at the moment the Chimera Tool does not have such a service, for that phone) and then use the IMEI REPAIR.

Best regards
Sab
Chimera Team


Quote:
Originally Posted by preacher23 View Post
Greetings:


Code:
Chimera Mobile Phone Utility version: 29.67.2050  2021-09-16
Repair started
Unable to detect IMEI number and baseband version. It seems that the modem does not work or the network is unavailable/disabled.
Gathering phone info...
Collecting information. Be patient! Do NOT disconnect the phone!
Model: SM-A125W
Carrier ID: XAC
Sales Code: BMC
Country Code: Canada
Timezone: America/New_York
Android Version: 11 [RP1A.200720.012] [SDK 30]
Build Date: Tue Jul 27 14:10:03 KST 2021
PDA Version: A125WVLU2AUG5 [july 2021, rev5]
CSC Version: A125WOYV2AUG5 [july 2021, rev5]
Board Platform: MT6765
Network Type: GSM
Multisim Config: SS
Knox Version: v30
Warranty Bit: 1
Security Patch: 2021-07-01
Em Did: 5925C15534F3
Repair imei...
Restarting phone.
Waiting for ADB connection. Be patient! Do NOT disconnect the phone!
The operation is in progress. Be patient! Do NOT disconnect the phone!
Unknown modem
Finished at local time: [09.16.21 11:39:59]
WorkID: 150676483
  Reply With Quote
Old 09-22-2021, 08:33   #7 (permalink)
Junior Member
 
Join Date: Nov 2007
Posts: 13
Member: 633412
Status: Offline
Thanks Meter: 1
is the repair EFS feature planned for the A125W ?
  Reply With Quote
Old 09-22-2021, 09:26   #8 (permalink)
Product Manager
 
Chimera Tool's Avatar
 
Join Date: Jul 2012
Posts: 18,969
Member: 1787203
Status: Offline
Thanks Meter: 19,356
reply

Dear User,

At the moment no, but based on the recent issues with some devices, I do believe that we will start working on it. Of course, if we will have any changes in the Tool, we will inform you, and every other user as well.

Best regards
Sab
Chimera Team


Quote:
Originally Posted by preacher23 View Post
is the repair EFS feature planned for the A125W ?
  Reply With Quote
Old 09-23-2021, 17:50   #9 (permalink)
Junior Member
 
Join Date: Nov 2007
Posts: 13
Member: 633412
Status: Offline
Thanks Meter: 1
Greetings again,


I was able to successfully update the IMEI (WorkID: 151656230) but unfortunately the IMEI cert still shows fail in *#0011#


I keep running patch certificate in chimera (WorkID: 151656614) and it says Successfully finished but the IMEI certi still shows fails in the service mode menu


What options do i have to fix the imei certificate ?


Wait for an update?

Last edited by preacher23; 09-23-2021 at 17:51. Reason: clarity
  Reply With Quote
Old 09-24-2021, 10:07   #10 (permalink)
Product Manager
 
Chimera Tool's Avatar
 
Join Date: Jul 2012
Posts: 18,969
Member: 1787203
Status: Offline
Thanks Meter: 19,356
reply

Dear User,

Did you write a new Cert to the device before?

Quote:
Originally Posted by preacher23 View Post
Greetings again,


I was able to successfully update the IMEI (WorkID: 151656230) but unfortunately the IMEI cert still shows fail in *#0011#


I keep running patch certificate in chimera (WorkID: 151656614) and it says Successfully finished but the IMEI certi still shows fails in the service mode menu


What options do i have to fix the imei certificate ?


Wait for an update?
  Reply With Quote
Old 09-26-2021, 05:23   #11 (permalink)
Freak Poster
 
Join Date: Apr 2013
Location: Jeddah, Saudi Arabia
Posts: 342
Member: 1911337
Status: Offline
Thanks Meter: 37
a125w imei not found

Quote:
Originally Posted by preacher23 View Post
Hey there,


I have a fully functional SM-A125W and another one that keeps losing IMEI after factory reset and making a phone call.


I just plugged in the fully functional one, and it's saying (in MTK mode) that the imei was not found.


Also, the one that keeps losing it's imei and baseband after the first phone call after a factory reset, i tried the restore imei function and it didn't work either.


Code:
Chimera Mobile Phone Utility version: 29.61.0725  2021-09-14
Autodetect features
Initializing...
Identifying...
Reading data from the phone...
Autodetect features
Reading data from the phone...
Couldn't mount userdata. Probably it's encrypted.
IMEI not found
WorkID: 150424170


Did u solved the problem?
  Reply With Quote
Old 09-28-2021, 08:54   #12 (permalink)
Junior Member
 
Join Date: Nov 2007
Posts: 13
Member: 633412
Status: Offline
Thanks Meter: 1
i have not solved the problem yet.

I factory reset the phone, then I took a backup of NVDATA partition, then i made the first phone call and the IMEI showed as unknown, baseband unknown and then i took another backup of NVDATA, i mounted both backups in linux and looked at what happened:

After investigating the nvdata partition, and comparing it with the partition of the working phone, i realized there are two files missing in the broken phone:

AllFileCheck
AllMapCheck

These files after the first phone call are restored, but it trips the KG from Checking to Prenormal.

Also:

In the folder /md/NVRAM/NVD_DATA these are some of the changed:
CK10_001
CK14_000
EC75_002
EC76_008
EX03_000 (this file is added)
EX04_000
FILELIST (this file is added)
IM03_001
(and about 10 more files changed)


In the folder /md/NVRAM/NVD_IMEI these files are changed:
INFO_FILE
FILELIST
IP03_001
IP21_000

Also in the folder /md/NVRAM/CALIBRAT this file is changed:
FILELIST

Also in the folder /md/NVRAM/NVD_CORE this file is ADDED (it was not there before, perhaps the incorrect odin flash ruined that sector where the file was):
FILELIST


These changes to the partition cause the IMEI+Baseband to report as UNKNOWN

After a factory reset the imei and baseband comes back.

I tried to remove knox after gaining root but that is not possible, the phone becomes unusable.

I will try to work on the partition and see if there's a way to "restore it" back to working order, but i'm not too sure what is going on, i don't have the source code, i'll try and look at the logs or look at the system logcat to see if it really is KNOX that is messing things up.

I will also try to rewrite the IMEI and put it in airplane mode to see if the patch works.

Does anyone have any specifics on what CHIMERA is patching? maybe i can extract the working IMEI certificate and restore it manually?

I'll keep at it and figure this out eventually

Last edited by preacher23; 09-28-2021 at 08:58. Reason: more info
  Reply With Quote
Old 10-03-2021, 03:57   #13 (permalink)
Junior Member
 
Join Date: Nov 2007
Posts: 13
Member: 633412
Status: Offline
Thanks Meter: 1
Does anyone know how to rebuild NVRAM using a donor NVRAM?

Unpack? Edit? Any tools available?
  Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


 



All times are GMT +1. The time now is 21:16.



Powered by Searchlight © 2021 Axivo Inc.
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2021 DragonByte Technologies Ltd.
- GSM Hosting Ltd. - 1999-2017 -
Page generated in 0.21835 seconds with 7 queries

SEO by vBSEO