GSM Shop GSM Shop
GSM-Forum  

Welcome to the GSM-Forum forums.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features.
Only registered members may post questions, contact other members or search our database of over 8 million posts.

Registration is fast, simple and absolutely free so please - Click to REGISTER!

If you have any problems with the registration process or your account login, please contact contact us .

Go Back   GSM-Forum > GSM & CDMA Phones / Tablets Software & Hardware Area > Sony Ericsson > Sony Ericsson Hardware Repair

Sony Ericsson Hardware Repair Post here your Hardware Repairing Hints or Problems with SonyEricsson and Sony Phones.

Reply
 
LinkBack Thread Tools Display Modes
Old 10-16-2007, 13:19   #1 (permalink)
Major Poster
 
Join Date: Sep 2004
Age: 50
Posts: 49
Member: 82399
Status: Offline
Thanks Meter: 0
W850 Display problems


Display white flashing after power on.
problems firmware or hardware?
tips for resolving?


many thanks for all
  Reply With Quote
Old 10-17-2007, 06:49   #2 (permalink)
Freak Poster
 
Join Date: Nov 2006
Posts: 155
Member: 388978
Status: Offline
Thanks Meter: 88
may be firmware, try to flash.
  Reply With Quote
Old 10-17-2007, 06:59   #3 (permalink)
Temporary banned !!
 
Join Date: Jul 2007
Location: Toketek
Age: 39
Posts: 780
Member: 546766
Status: Offline
Thanks Meter: 51
full flash se tool or cruiser i hope solved your problem
  Reply With Quote
Old 10-17-2007, 09:50   #4 (permalink)
Major Poster
 
Join Date: Sep 2004
Age: 50
Posts: 49
Member: 82399
Status: Offline
Thanks Meter: 0
Thanks for help.
Phone is a prototype
CB5 FP1

is it possibile flashing ?

many thanks
  Reply With Quote
Old 10-23-2007, 19:46   #5 (permalink)
No Life Poster
 
Join Date: May 2005
Location: iran
Age: 39
Posts: 560
Member: 143648
Status: Offline
Thanks Meter: 179
i flash by all box
setool cruiser ub infinity jaf-se but my problem not slove
i have 2 pcs of this problen on w850
  Reply With Quote
Old 10-23-2007, 21:15   #6 (permalink)
Freak Poster
 
tasha326's Avatar
 
Join Date: Mar 2005
Location: Oxford, uk
Posts: 109
Member: 128457
Status: Offline
Thanks Meter: 2
I have a W850i. the screen went white and was blinking on and off. I`ve had to send it to be repaired as i have only had it a few weeks. The shop it was bought from wouldn`t do anything. they said sonyericsson has taken over the warrenty on their phones as there have been too many problems with them. I will NOT be getting a sonyericsson again after this one. Think i`ll stick to nokia in the future.
  Reply With Quote
Old 10-24-2007, 08:33   #7 (permalink)
Freak Poster
 
Join Date: Nov 2006
Posts: 155
Member: 388978
Status: Offline
Thanks Meter: 88
if your phone is prototype, pls flash carefully, because during the process flash may be fail. not power on.
  Reply With Quote
Old 10-24-2007, 08:34   #8 (permalink)
Freak Poster
 
Join Date: Nov 2006
Posts: 155
Member: 388978
Status: Offline
Thanks Meter: 88
the first, you 'd better to check main cable, before to flash.
  Reply With Quote
Old 10-24-2007, 13:30   #9 (permalink)
Junior Member
 
Join Date: Oct 2006
Posts: 13
Member: 361868
Status: Offline
Thanks Meter: 0
i have the same problem,flashing full ok,but same,pls help somebody
  Reply With Quote
Old 10-28-2007, 22:29   #10 (permalink)
Freak Poster
 
Join Date: Mar 2006
Posts: 174
Member: 248030
Status: Offline
Thanks Meter: 29
Quote:
Originally Posted by sandro123 View Post
Display white flashing after power on.
problems firmware or hardware?
tips for resolving?


many thanks for all
Most likely faulty flex/and or top keypad membrane..
  Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
thread Thread Starter Forum Replies Last Post
Any new solution for W850 display problem? jawad8305 Sony Ericsson Hardware Repair 7 06-12-2010 06:30
5800 Display Problem (With Display On FBUS Cable But No Display using Regular Battery eyestrain Nokia Base Band 5 ( BB-5 ) 1 06-21-2009 21:11
W850 network problem curtisbcm Cruiser Suite 3 10-28-2008 06:46
w850 weird problem help please nafg Cruiser Suite 3 07-01-2007 18:45
w850 unlock problem. webcenter Cruiser Suite 16 12-03-2006 12:32

 



All times are GMT +1. The time now is 23:27.



Powered by Searchlight © 2019 Axivo Inc.
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
- GSM Hosting Ltd. - 1999-2017 -
Page generated in 0.33669 seconds with 8 queries

SEO by vBSEO